MozillaZine

Netscape 7.0 News and Reviews

Thursday May 23rd, 2002

Netscape 7.0 Preview Release 1 has received quite a lot of news coverage in the last twenty-four hours. CNET News.com kicks things off with a short article while ZDNet has the same story with reader comments. Reuters says that the beta has more features aimed at mainstream consumers while vnunet.com claims that Netscape is going for the corporate market. InfoWorld feels the need to mention Star Wars and Slashdot also has an article.

Early reviews are looking good. CNET's Rex Baldazo gives the beta 7 out of 10 but he still hasn't read the Release Notes. PCWorld.com brings us more Star Wars analogies and eWEEK thinks that the final version will be "an excellent upgrade." ZDNet AnchorDesk executive editor David Coursey spends an entire column saying how great Netscape 7.0 is before declaring that it's not worth upgrading. His accompanying radio show features comments from Netscape's Sol Goldfarb and Rex "Release Notes" Baldazo.

UPDATE! Also check out this piece from Forbes.com and some commentary from Guardian Unlimited, the online edition of the UK's The Guardian newspaper.

ANOTHER UPDATE! The Register also has a story. The second and third paragraphs sound kind of familiar.

Thanks to everyone who sent us links to news and reviews.


#2 here's my review...

by xkalibur

Thursday May 23rd, 2002 11:41 AM

You are replying to this message

I can't use it on redhat 7.3. I've been using Mozilla release candidate's and Netscape 6.x releases for quite some time, very familiar with the install process. I put Netscape7 in /usr/lcoal/netscape7, and it won't start. Yes i ran as root first to register components, doesn't make a difference. I tried running on a completely fresh, new user account, same problem. It just creates a .mozilla directory with "appreg" in and that's it. If i run and then exit Mozilla 1.0rc2, which creates a "default" profile, then at least Netscape7 will bring up the Profile Manager. But it won't start a profile! Just says "the directory cannot be found". So I try to create a new profile, and it won't let me! The destination folder is blank, and when i click "Choose Folder", i get an empty file selector that does nothing. If I check "show hidden files", it crashes! I've tried removing the nautilus mozilla 0.9.9 from my path, and even killing off nautilus. No go. Any ideas? I'm really anxious to try the new AIM and just see what teh release is like. Thansk...