MozillaZine

SeaMonkey 1.1.4 Released

Monday August 6th, 2007

Robert "KaiRo" Kaiser has announced the release of SeaMonkey 1.1.4. This upgrade to the all-in-one Internet suite fixes several security issues, detailed in the SeaMonkey 1.1.4 section of the Mozilla Foundation Security Advisories page. The three issues listed, which include a SeaMonkey variant of the firefoxurl:// security flaw, also affected Mozilla Firefox and Mozilla Thunderbird (they were patched in those applications' 2.0.0.5 and 2.0.0.6 releases).

All SeaMonkey users are urged to upgrade, including users of the now unsupported SeaMonkey 1.0.x (last updated when SeaMonkey 1.0.9 was released simultaneously with SeaMonkey 1.1.2 in May). The SeaMonkey team is also urging users of the Mozilla Application Suite, Netscape 7, Netscape 6 and Netscape Communicator 4.x to upgrade to SeaMonkey 1.1.4. "All those older software packages suffer from a large and steadily increasing number of security vulnerabilities because they are no longer being maintained," KaiRo explains. "SeaMonkey 1.1.4 is a modern, drop-in replacement, providing the same familiar suite functionality with additional features and fully up to date security fixes." The SeaMonkey project is a community-driven continuation of the Mozilla Application Suite, which formed the basis of Netscape 6 and 7 and shares similarities with Netscape Communicator 4.x.

SeaMonkey 1.1.4 can be downloaded from www.seamonkey-project.org. More details can be found in the SeaMonkey 1.1.4 Release Notes.


#5 Re: Auto updates?

by buff

Thursday August 9th, 2007 4:57 AM

You are replying to this message

i got an update and i was using 1.1.3. When i opened seamonkey it asked me to update. i let it an here i am at 1.1.4. seems to work fine on updating.