MozillaZine

Mozilla 0.9.8 Released

Monday February 4th, 2002

Mozilla.org today released Milestone 0.9.8 of Mozilla. This release includes the new OS rendered classic theme on Mac OS X and Windows XP, a partial rewrite of the addressbook adding a quicksearch and additional printing enhancements, support for MNG animations, DOM Inspector on the Mac, dynamic theme switching, inline CSS support in composer, and so much more. You can check out the release notes for more information on what's changed and other issues.

Builds are available on mozilla.org's releases page, or on the FTP Server.

With 0.9.8 released, attention turns to 0.9.9, which many believe to be the last milestone prior to 1.0.


#114 FIXING JAVA PROBLEMS

by starless

Wednesday February 6th, 2002 5:26 PM

You are replying to this message

In a previous thread I posted a message about Mozilla 0.9.7 crashing on pages using Java.

The same thing was happening with 0.9.8. However, by following the following instructions the pages that previously crashed mozilla now work fine for me.

It appears the Mozilla team should be distributing a different plugin!

----------From: Jason Read (<jason@jasonandtrisha.com>) Subject: Re: JRE kills mozilla 0.9.x (linux) Newsgroups: netscape.public.mozilla.java View this article only Date: 2001-10-11 10:27:31 PST

> LoadPlugin: failed to initialize shared library /usr/lib/mozilla/plugins/java2 [/usr/lib/mozilla/plugins/java2: cannot read file data: Is a directory]

------------------------------------------------------------------------------

I just worked through this problem w/ RedHat 7.1. Here is the solution that worked for me:

1. Download latest JRE from <http://java.sun.com> 2. Extract to /usr/java/ (or whatever directory you want to use) 3. Go to the /usr/lib/mozilla/plugins directory 4. Remove the existing libjavaplugin_oji.so file and java2 directory 5. Create a symbolic link to the plugin in the jre directory as follows: ln -s /usr/java/jre1.3.1_01/plugin/i386/ns600/libjavaplugin_oji.so . 6. Close all mozilla sessions 7. Restart mozilla and close immediately ( this is due to some bug ) 8. Restart mozilla again 9. You should be ready to go at that point

For more info see the install directions for the jre at java.sun.com.

I guess the install performed by the plugin manager is faulty... I'm sure it will be fixed soon. But for now this appears to work.

--jr

------------------------------------------------------------------------------

-------